Customized Standard Report layout going blank

  • Last Post 08 April 2020
madiha.fathima posted this 14 August 2019


I have customized the IFS standard report layout using Crystal Reports as a replacement to Standard Customer Invoice Report on right click. It was working fine until yesterday for all the companies we have on database. 

But today I added a section on report for a new company we now have on IFS/DB, and the report goes blank. I tried to debug by removing section but didn't work. Its just that, with this new company data report goes blank. It still works fine for all other company data we have on IFS. 

I am not sure if any extra care need to be taken when new data is added on IFS and update/modify something on this kind of report layout? Please help




Order By: Standard | Newest | Votes
madiha.fathima posted this 14 August 2019

Just to add up; we have custom view on which this layout is built  and not _REP standard. Out of IFS, the Crystal Report is populating the data for result key but not on IFS

Manulak Dis posted this 20 August 2019

It probably seems to be like an access issue.

Either the report view isn't accessible for IFSSYS, else the COMPANY isn't allowed to the user you are trying the preview with.

First, you should try with adding that object into the DATABASE OBJECTs of the report's presentation object (screenshot).

If that's not working, please follow the below process. [I hope you have technical skills. WIthout so, please play safe]
1. Open the report within Crystal Designer
2. Give data and preview the report with intended data (or it's OK if it's blank but you should make sure that the input variables should return a value outside IFS)
3. Go to DATABASE > SHOW SQL QUERY and get the report SQL
4. Log into the database as IFSSYS and check if it returns any data
~By that step you can clearly find which violates the access issues

If none of above helps, please share us a model report (attach here) so we can have a look to provide feedback

madiha.fathima posted this 20 August 2019

Thank you for that info.  I will try the options and let you know if it works,,



madiha.fathima posted this 26 August 2019


I tried giving IFSSYS to views used in report didn’t work. I guess as you said company is not allowed to user to view? How can I troubleshoot this on ifs? For some reason I still couldn’t get ifssys access to run report query. Waiting for our IT admin team to get me access. TIA

chana05 posted this 30 August 2019

You can check it in 'Users per Company' window. This comes under Application Base Setup

madiha.fathima posted this 25 October 2019

Thanks. That report didn't work so we had to make a Quick report


But now i have same problem again, One of our custom Purchase Order print report is going blank for a new site we added on IFS. The Company is existing and under it we have about 50+ sites and this report works fine for all that sites. 

This is a crystal based report on Purchase Order->right click Print work copy-> here we have added layout option to print our layout defining on report definitions. it uses normal purchase order header and detail views with purch_info_services_rpt view to get result key.

Now we added a new site and my user id is part of that site and i made as my default site also. but no luck. It just prints/exports blank page. I tried troubleshooting is some field/section is creating issue, but no every time I run report for this new site data on IFS it goes blank. It shows data on Crystal/view for same result_key (out of IFS)


Please help. TIA

Manulak Dis posted this 27 October 2019

Have you added the row-based security to your Crystal quick report? By adding CR_WEB_UTIL_API.Cr_Web_Inti? 

madiha.fathima posted this 27 October 2019

I tried that as well. Actually this is just crystal layout configured same as rdl standard report so was not required actually. But adding row level Security also didn’t help

ERPTechServ posted this 06 November 2019

Check the following grants on the view Exist:






It may be worth creating the _REP view as an IAL object with the "Live Data" option set then once you refresh the Dictionary cache you can allocate access in permission sets to this View in the IAL objects tab.

Try and avoid cross-schema views being brought into Crystal, this is hit and miss and in my experience it is easier to create a new view in the IFSAPP schema based on the standard _REP view (as you've done) and do all the joins in the new view so you present a single view to Crystal - I had a similar issue to yours recently and I solved it this way.




Manulak Dis posted this 08 April 2020

I hope your new issue is again with a Crystal Operational report?

Simply, open the report in Crystal Designer, run it with the user IFSPRINT and then give an available result key. If you don't see desired data, that's an issue with the report design, probably an incorrect join.

Solve that issue first, and then proceed to resiger the layout in iFS and test via IFS users.

Can you tell the progress of that test, so we can move step by step forward?